среда, 5 июля 2017 г.

Mesa Updates Debian: свежий графический стек для Debian 9

Приветствую. В связи с бурным развитием проекта Mesa в последние годы, многие пользователи стали обращать гораздо более пристальное внимание на графические решения от AMD и Intel. Для пользователей Ubuntu существует PPA-репозиторий со свежими версиями свободных видеодрайверов, что позволяет всегда иметь актуальный графический стек в своей системе. Начиная с Debian 8, свежая Mesa попадает в репозиторий Backports, только вот попадает она туда далеко не сразу после релиза. На это есть свои причины, как вы можете догадаться, но тем не менее - если вам нужна свежевышедшая Mesa здесь и сейчас, никакой возможности, кроме самостоятельной сборки, не существовало. Пришло время это исправить.



Данный репозиторий создан для Debian 9 и LMDE 3, и содержит в себе свежие стабильные версии свободных видеодрайверов для чипов AMD Radeon, Intel и Nvidia (Nouveau). В репозитории содержатся также Vulkan-драйверы Intel ANV и Radeon RADV. Пакеты в данном репозитории берутся из Debian Unstable (Sid) и пересобираются под Debian 9, дабы не ломать ничего в системе. Подключение весьма простое:

wget http://download.opensuse.org/repositories/home:/Sunderland93:/mesa-updates-debian/Debian_9.0/all/mesa-updates-debian_1.0-3_all.deb

sudo dpkg -i mesa-updates-debian_1.0-3_all.deb

sudo apt update && sudo apt full-upgrade

По вопросам работы репозитория пишите в комментариях, либо мне на почту samoilov.lex@gmail.com

5 комментариев:

  1. Доброго времени суток Алексей, часто посещаю Ваш блог в надежде почитать новые стать про Debian. Но увы они появляются не так часто как хотелось. Особенно я думаю будут интересны статьи в формате мини howto. Жду новых статей Ваш преданный читатель...

    ОтветитьУдалить
    Ответы
    1. Спасибо. Надеюсь в ближайшем будущем почаще обновлять ленту в блоге. Дела меня съедают с головой

      Удалить
  2. Warning: apt-key should not be used in scripts (called from postinst maintainerscript of the package mesa-updates-debian)
    gpg: WARNING: nothing exported
    gpg: no valid OpenPGP data found.
    gpg: Total number processed: 0
    dpkg: ошибка при обработке пакета mesa-updates-debian (--install):
    подпроцесс установлен сценарий post-installation возвратил код ошибки 1
    При обработке следующих пакетов произошли ошибки:
    mesa-updates-debian
    И что теперь делать?

    ОтветитьУдалить
    Ответы
    1. Попробуйте переустановить пакет для начала. sudo apt install -f . Только что перепроверил у себя - пакет устанавливается, репозиторий работает

      Удалить
    2. а как переустановить, можете подсказать команду.

      Удалить